Ads 468x60px

Thursday, November 24, 2011

Maipu - Failover Configuration Using Static Route

Hi , I want to share one testing report with all of you. This is majorly focused on Fail over configuration with static routing.. Below are objectives for testings...

Objective - 
  • R1 Client Router both interface should be UP every time.
  • PC should ping 20.1.1.1 Loopback interface continuously.
  •  Auto Failover should happen.
  • One time one port should forward traffic to ISP router.
  • As the primary F0 links fails, The F1 should get active to forward traffic to ISP router.
  • After restoration of F0 links, The F0 should forward the traffic to ISP router.
Topology:





Configurations

(Client)R1-

interface fastethernet0
 ip address 10.20.20.2 255.255.255.0
 media-type fiber
 rate 100
 duplex full
 load-interval 30
 exit


interface fastethernet1
 ip address 10.20.30.2 255.255.255.0
 media-type fiber
 rate 100
 duplex full
 load-interval 30
  exit


interface vlan1
 ip address 10.1.1.1 255.255.255.0
 exit



ip route 0.0.0.0 0.0.0.0 fastethernet0
ip route 0.0.0.0 0.0.0.0 fastethernet1 10


(ISP)R2 –

interface loopback0
 ip address 20.1.1.1 255.255.255.0
 exit


interface fastethernet0
 ip address 10.20.20.1 255.255.255.0
 media-type fiber
 keepalive gateway 10.20.20.2 4
 rate 100
 duplex full
 load-interval 30
 exit


interface fastethernet1
 ip address 10.20.30.1 255.255.255.0
 media-type fiber
 keepalive gateway 10.20.30.2 4
 rate 100
 duplex full
 load-interval 30
 exit


ip route 10.1.1.0 255.255.255.0 10.20.20.2
ip route 10.1.1.0 255.255.255.0 10.20.30.2 10

Testing Scenarios – 

10.1.1.2  ping to Gateway to observe delay….


10.1.1.2  (PC) ping to 20.1.1.1 (Loopback interface in ISP Router)


Currently in this screen shot, both interface as UP. Primary link F0 is forwarding traffic to ISP router.


After Primary link is down –
You can see F0 is down and F1 is up, F1 is forwarding traffic to ISP router.


Below is ping snap shot from 10.1.1.2 (PC)  to 20.1.1.1 ( ISP loopback interface)


10.1.1.2 (PC) pinging to Gateway IP


After restoration of link
As the link is restored, F0 interface is active interface to forward traffic to ISP router.


The F1 forwarding is shifted to F0 interface.  PC (10.1.1.2) pinging to ISP router loopback (20.1.1.1)


PC pinging to Gateway 10.1.1.1




Above testing successfully demonstrates above objectives are successfully. 

Hope this information will help you. 

Thanks for reading.. 

For feedback. Plz comment with Name and Mail ID.. 








Thursday, November 3, 2011

Maipu 3840 MTU Details

Hi, Today one of my client raised a query about MP 3840 MTU details about all 4 Gig interface. 
As MP 3840 is aggregation router, some time we need to modify the MTU of interface as per requirement. 
So I would like share same details here, Which can be helpful for all. 
MP 3840 Gig 0, you can configure max MTU of 1800 under Gig 0  interface for any peer device.
But Gig 1/2/3 , if speed is configured as 100 M or negotiating with 100M peer device. Then it will support max MTU 1500. If negotiating with 1000M or configured as 1000M , then it can support max 1800 MTU.


Hope this information will help in some critical scenario. 


Thanks for reading...

Tuesday, October 11, 2011

Maipu 1800 IPv6 Testing - BGP+


MP1800 -xx Series Routers support OSPFv3, IPv6 RIPng, IPv6 IS-IS, IPv6 BGP4+ and static IPv6 routing.

In this section we will use above topology for IPv6 BGP+ testing. 

Configuration Template -

Router-A:

hostname R-A
ip mef

interface loopback0
 ipv6 enable
 ipv6 address 1::1/128
 exit

interface fastethernet0
 ipv6 enable
 ipv6 address 192::1/64
 exit
                            
router bgp 100
 no auto-summary
 no synchronization
 bgp router-id 1.1.1.1
 neighbor 192::2 remote-as 200
 no neighbor 192::2 activate
 address-family ipv6
  network 1::1/128  
###network loopback 0 into BGP+ session, then peer BGP neighbor can learned this routing ###
  neighbor 192::2 activate
  exit-address-family
 exit


Router-B:


hostname R-B

interface fastethernet0
 ipv6 enable
 ipv6 address 192::2/64
 exit

interface fastethernet1
 ipv6 enable
 ipv6 address 193::1/64
 exit
                                 
router bgp 200
 no auto-summary
 no synchronization
 bgp router-id 2.2.2.2
 neighbor 192::1 remote-as 100
 no neighbor 192::1 activate
 address-family ipv6
  neighbor 192::1 activate
  exit-address-family
 exit



Testing Results Output:

On Router - A


On Router - B


Router-B Routing Table:


Router-B can reach to Router-A Loopback 1::1/128.



This above testing is basic testing of IPv6. For more detailed configurations. You can download it from Maipu website.

Hope this post will help you for IPv6 understanding.

Thanks for reading ...




Thursday, September 22, 2011

Maipu IOS Upgradation Video Practice -2


Hi All, In this section we will see about Maipu Router IOS upgradation from Monitor Mode. As I already posted video practice for Shell in previous post. You can find that in video label. 
This Maipu IOS upgradation video is from monitor mode, Currently used model is MP 801E. Rest all model the process is same. 


video


Related post for Monitor upgradation process - 


http://startnetworks.blogspot.com/2011/05/maipu-ios-upgradation.html


Youtube Links - 
http://www.youtube.com/watch?v=NbA_pwjhEWs

You can find same video in youtube also. You can have flexibility in watching video as required screen size in youtube. 

I hope you will like this video, For likes and queries. Plz put comments. 


Thanks for watching video and reading... 







Tuesday, September 20, 2011

Maipu IOS Upgradation Video Practice - 1

Hi All, In this section we will see about Maipu Router IOS upgradation from CLI mode (Shell mode). As I already posted many times about Maipu IOS upgradation process –
This is Maipu IOS upgradation video for MP 801E, The rest Router models upgradation process is also same . 



video


YouTube Links -
Link - http://www.youtube.com/watch?v=lzHY0iBicRc

I tried to share more information in form of Video.

I hope it is easy to understand and remember in form of Video and same time Plz refer document /post to ensure successful upgradation.

Related post for Maipu IOS upgradations: 





Thanks for watching reading and watching Video…

Hope you like it. For Likes and queries, Plz comment with your Name and Mail id. 

Monday, September 19, 2011

Maipu Support Contacts Details

Hi All, Please find Maipu support New Contact Details


Global Technical Support Team - techsupport@maipu.com


This team is dedicated for technical support for technical queries and technical issues regarding Maipu Products and configurations. 


Global Maipu Technical Training and Certification - techcert@maipu.com

This team is dedicated for Training supports, You can receive Training Material from this team. For appearing Maipu certification examinations you can request to this team. As per schedules and availability, This team will schedule your examinations online.


For Maipu Certification Details - Click Here for Maipu Ceritifcation Track


Hope these contact details will help you to contact Maipu Directly for your support queries.


Plz put comment for any queries... 


Thanks for reading...



Saturday, September 17, 2011

Maipu Supported SNMP Traps

Hi , In this section. I will share the information of SNMP traps supported by Maipu Routers. Many times we require traps information for notification and monitoring. 


Maipu Routers support below SNMP traps:



snmp-server start
snmp-server view default 1.0.8802 include
snmp-server view default 1.1.2 include
snmp-server view default 1.3.111 include
snmp-server view default 1.3.6.1 include
snmp-server community public view default ro
snmp-server enable traps alarm
snmp-server enable traps bgp established
snmp-server enable traps bgp backward-transition
snmp-server enable traps frame-relay dlci-status-change
snmp-server enable traps frame-relay pvc-connect-status-change
snmp-server enable traps frame-relay pvc-connect-status-notify
snmp-server enable traps ospf if-authen-failure
snmp-server enable traps ospf virtif-authen-failure
snmp-server enable traps ospf if-config-error
snmp-server enable traps ospf virtif-config-error
snmp-server enable traps ospf if-state-change
snmp-server enable traps ospf virtif-state-change
snmp-server enable traps ospf nbr-state-change
snmp-server enable traps ospf virtnbr-state-change
snmp-server enable traps ospf if-rx-bad-packet
snmp-server enable traps ospf virtif-rx-bad-packet
snmp-server enable traps ospf tx-retransmit
snmp-server enable traps ospf virtif-tx-retransmit
snmp-server enable traps ospf originate-lsa
snmp-server enable traps ospf max-age-lsa
snmp-server enable traps ospf lsdb-approaching-overflow
snmp-server enable traps ospf lsdb-overflow
snmp-server enable traps snmp authentication
snmp-server enable traps snmp coldstart
snmp-server enable traps snmp warmstart
snmp-server enable traps snmp linkdown
snmp-server enable traps snmp linkup
snmp-server enable traps snmp enterprise snmp-agent-up
snmp-server enable traps snmp enterprise snmp-agent-down
snmp-server enable traps snmp enterprise rmon-rising
snmp-server enable traps snmp enterprise rmon-falling
snmp-server enable traps veth remote-status
snmp-server enable traps isis
snmp-server enable traps remote-ping probe-failed
snmp-server enable traps remote-ping test-failed
snmp-server enable traps remote-ping test-complete
snmp-server enable traps port-shutdown
snmp-server enable traps vlan
snmp-server enable traps ip-sla
snmp-server enable traps cellular insert
snmp-server enable traps cellular pullout
snmp-server enable traps cellular pin-invalid
snmp-server enable traps cellular pin-changed
snmp-server enable traps cellular wan-media-change
snmp-server enable traps cellular dial-fail
snmp-server enable traps cellular uim-no-exist
snmp-server enable traps vrf
snmp-server enable traps spanning-tree topology-change
snmp-server enable traps spanning-tree new-root-port
snmp-server enable traps spanning-tree new-root-bridge

You can enable any traps as per your requirements. 

Hope this information will help you in SNMP configuration. 

Thanks for reading...

For any questions, Plz comment with your Name and Mail ID. 

Tuesday, August 30, 2011

Understanding IPv6 Extension Headers in Details

In last post, we have seen all basics of IPv6 headers. As we know the IPv6 header is very efficient as compared to IPv4 header due to less fields in IPv6 header and extension header approach in Next header field.

These extension headers are added only if needed. Extension headers are appended after the basic datagram header as per requirements.

The extension headers numbers may be more in a single datagram, so in this case how to identify, how many extension headers are placed ?  For this Header chaining mechanism is introduced.
It helps to identify next headers and upper layer protocol information.

In IPv6 the Next Header field has below responsibilities
  1. If there is an extension header present, the Next Header field determines its type and value. Every extension header also contains its own Next Header field identifying the next following data.
  2.  It finds next extension header with particular value. Any extension headers  will be chained with other header by simply announcing who is next header.
  3. The last extension header in Next header fields identifies the upper-layer protocol (TCP/UDP) to which the datagram content should be passed.


Below you can find the details about extension headers identification numbers/values and protocol identification numbers.



 As the IPV6 is having this approach of extension headers, When the number of Extension headers increases, It is arranged sequentially , most important header for all node (router/device) will be placed first and header important for destination will be placed at last. That means no need to look into each Extension header field for processing. The first extension header will tell what next action needs to be taken.

This process improves the processing performance significantly.


Below diagram process shows some examples of Header chaining process for better understanding. The first datagram is plain IPv6 and TCP, the second one contains a single extension header (Routing) and the chain in third datagram includes two extension headers (Routing and Fragment).

IPv6 header Next = 6 (TCP)
TCP segment
 Above a plain datagram without any extension headers.


IPv6 Header Next =43 (Routing)
Routing Header Next =6 (TCP)
TCP segment
 Datagram containing Routing extension header in Next header.


IPv6 Header Next =43 (Routing)
Routing Header Next =44 (Fragment)
Fragment Header Next =6 (TCP)
TCP segment
 Datagram containing Routing and fragment extension headers.



Let’s see some important extension headers in details -

Routing Header

The Routing extension header is responsible for route information of the datagram/packet. It allows user to define some sequence of nodes/devices of (IPv6 addresses) from which the datagram/packet should must pass/travel to reach destination.

Two types of options are defined in Routing extension header for efficient processing –

Type 0  - is a normal,  allows all router addresses in sequence to reach to destination.
Type 2 -  is a used for mobility purposes  (source and destination)

Type -0 in Details,

In this case the Routing header contains two pieces of information:

1. Sequence(path) of nodes/routers  with IPv6 addresses to reach destination.
2. Identifies how many routers are passed and how many are remaining to reach destination.

Working of Type-0 (Routing headers) headers in action –
  • The sender use this feature and adds routing header to datagram/packet.
  • In this header next hop/node address is placed as address of first checkpoint which is in between router in path to reach Destination address.
  • It also adds the Routing header containing the sequence of remaining routers/nodes information.
  • The final destination (its real target) is the last member of this sequence. 
  • When delivered to the Destination Address (actually the first node/Router) the router finds the Routing header and realizes that i am just a path router.
  • So it swaps the address in the Destination Address and the next address from behind of the Routing header and remaining sequence left is decreased by 1 and datagram/packet is sent to the next node/router.


This process is executed on every Router.As the remaining sequence number is left 0, that means it reached to destination.


Type 2  in Details –

It just contains destination address. That means it is directly delivered to destination address using source as any temp address also known as home address. When the packet delivered to destination with home address, it present the data to destination with upper layer protocols details with home address.

Fragmentation Extension header-
  
Every lower-layer technology will use IPv6 to transport data in future over network. To transport datagrams over IPv6 , The lower layer devices have to consider packet size for IPv6 also known as MTU (Maximum Transmission Unit).
If the IPv6 datagram is longer than specified MTU 1500 bytes, the data must be divided/fragmented/chopped up and divided into set of smaller IPv6 datagrams, called fragments.
Fragments are transported over IPv6 network from source to destination and assembled by the receiver/destination to create the original packet/datagram. This is known as fragmentation.


Let’s see how the fragment extension headers works in IPv6 next header. The fragment extension header containing three important fields to perform fragmentation proces –

  • Identification field -  It helps to identify same datagram/packet from all, Which is originally fragmented from source. It is identified with unique values.
  • Offset -  It helps to identify the sequence numbers of fragments and re-assemble the fragmented data/fragments properly using sequence numbers.
  • More fragmentsThis flag announces if this fragment is the last one or if another fragment is still there.


The helps to destination to identify the full datagram is arrived or not from source.

Process - The destination router collects all packets having Fragmentation Next header, using the inside fields. It identifies the fragments, using offset it reassembles properly.  Using more fragments it confirms that all fragments for particular packet is received.

But fragmentation affects router packet processing, So IPv6 came with new guidelines about MTU-

  • Minimum allowed MTU on IPv6 supporting links is 1280 Bytes (1500 Bytes is recommended). It decreases the need for fragmentation every time. 
  • Only the sender is allowed to fragment a datagram/packet. If some in between Router needs to forward it through a link with insufficient MTU, It must drop the datagram and send an ICMP message to the sender informing datagram drop and the MTU mismatch information.
  • Every router has to know the Path MTU for all its neighbors to keep the communication efficient.
  • Path MTU is the supported MTU size with route between the sender and destination. This is the largest datagram size deliverable with particular route. Source should try to send datagrams/packets of this size ,since they are the most efficient.



Path MTU is calculated based on ICMP messages. The packet is sent out on link with MTU value of our device, Then if the ICMP fail message is received due to different MTU size in path, Then sender decreases MTU size and send the ICMP message again, This process will continue till the packet is reached to destination.
            The MTU value is noted when the ICMP message is reached at destination and shared to neighbours as Path MTU.

Options Extension header-

IPv6 header is of 40 bytes fixed. The options is a extension header in IPv6. Options Header provides some additional information related to the datagram for processing packets same like IPV4. It is very important field in IPv4 for special packet processing requirements,

Here IPv6 options  header are having two groups:

Hop-by-Hop options - Options dedicated to every node forwarding the datagram,
Destination options - Options intended for the destination host only.


If Hop-by-hop options is used then it is placed at the start of all extension headers, since they are important for every router for forwarding the datagram. This option inform router that some important message is for you with Router alert - like jumbo frame and RSVP messages.

Destination options is mostly placed at last of extension headers. It is used in IPv6 Mobility supported  applications



In this post, I tried to explain details about IPv6 Extension headers simply with key points. I know this post is lengthy, But every topic was related to each other. So I tried to complete this all in same post itself.

Hope you didn’t get bored while reading. I tried to put in points so that it can be easily understandable.

Hope you like this post..

For any likes and feedback, Plz comment with your Name and mail Id. For new users you can use Name/URL option in account.

Thanks for reading…
Related Posts Plugin for WordPress, Blogger...